Requirements

Tales of the Navigator requires the 1.1 Patch or higher from Irrational and Freedom Force X to be installed.

Tales of the Navigator: Epsiodes 1 and 2

"In Search of the Cracks"

"The Great Racetrack"


IMPORTANT!: You need FFX 2.6 installed to run the later missions successfully. Without these the opponents will often stand around and do nothing! See the instructions below!

Navigator 2.0 (48M)
Combines all nine playable missions to date in a single download

Requires the Irrational 1.1 or 1.2 Patch, followed by FFX 2.6 or equivalent to work.


Installing and Running

  • If you don't have FFX, install V2.3 first, from the FFX pages on this site.
  • Run the installers listed above in the given order. If FF is installed in C:\Program Files\Irrational Games\Freedom Force, you wont need to change the install directories.
  • There's a shortcut for running the Navigator mod in the root Navigator folder. Copy this to your desktop if you like. You'll need to change the path to the executable if FF isn't installed in the standard path above.


Tales of the Navigator: Epsiode 3

"The Shining City"


IMPORTANT!: You need FFX 2.6 installed to fully run Tales of the Navigator.

Navigator 3.0 (4M)
Install over the top of Tales of the Navigator Parts 1 and 2.

Requires the Irrational 1.1 or 1.2 Patch, followed by the FFX Squared 2.6 or equivalent to work.